1. Home
  2. /
  3. Notícia
  4. /
  5. Descontinuado suporte NPAPI nos...

Descontinuado suporte NPAPI nos navegadores de Internet

A maioria dos navegadores de Internet descontinuaram o suporte ao NPAPI deixando de funcionar diversos plugins como o Java Runtime, Adobe Flash Player, Silverlight, entre outros. Dessa forma diversos sistemas passaram a utilizar plugins alternativos ou desenvolveram seus projetos em outras linguagens de programação, esse foi o caso dos Bancos que passou a utilizar um plugin chamado warsaw.

O warsaw é um plugin desenvolvido pela Diebold Nixdorf para funcionar alguns Bancos. Esse plugin está funcionando sem problemas na maioria dos Bancos, porém devido a uma modificação realizada por alguns Bancos esse plugin não funciona corretamente em algumas distribuições Linux e ambientes gráficos. Por isso se você não usa o Ubuntu com ambiente gráfico Unity ou Linux Mint com ambiente gráfico Cinnamon provavelmente terá problemas em fazer o plugin rodar nesses Bancos que realizaram a modificação do pacote como é o caso do Banco do Brasil.

Para acessar o sistema do Banco do Brasil é necessário ter o hda para instalar o warsaw e certificados, já que o mesmo não usa a versão desenvolvida pela Diebold Nixdorf e sim uma versão modificada, já que ao instalar o warsaw da Diebold o Banco pede uma nova versão que somente o mesmo possui. No caso do BB é necessário ter o Ubuntu ou Mint e ambiente gráficos baseados no GNOME como é o caso do Unity e Cinnamon.

Já outros Bancos como Itaú e Caixa Economica Federal podem ser instalados na maioria dos ambientes gráficos e distribuições Linux como Debian, Ubuntu, Mint, entre outros baseados no Debian/Ubuntu.

Caso ainda precise utilizar o Java Runtime para acessar o Android Studio, NetBeans, Eclipse, entre outros, criamos um repositório para mante-lo atualizado, clique aqui

Você pode gostar também:

Deixe um comentário

Seja o Primeiro a Comentar!

Notificar a cada
avatar
wpDiscuz